EIGRP Static Neighbor

        Generally, we will be forming EIGRP neighbors with the help of multicast IP Address (224.0.0.10). But, we can also form neighbor-ship manually (UNICAST/ STATIC) neighbor. This is referred as EIGRP STATIC neighbor.

Points to be noted for EIGRP static neighbor:
  • Routers will not send hello packets with 224.0.0.10 IP
  • Although we configure EIGRP statically, we need to advertise the network to for neighbor-ship
  • This can be used to used for Security purpose.
Lets say we have 3 routers (R1, R2 and R3) are connected via switch (Multi-access network) as below. If you want to form neighbor-ship between R1 and R2, and there should not be any neighbor-ship with other routers in the multi-access network, which means no neighbor-ship between (R1 and R3) and between (R2 and R3).


Router R1 configuration:

R1#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.12.1    YES NVRAM  up                    up
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Loopback0                  1.1.1.1         YES NVRAM  up                    up

R1#
R1#show running-config interface fastEthernet 0/0
Building configuration...
Current configuration : 97 bytes
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 duplex auto
 speed auto
end

R1#show running-config interface loopback 0
Building configuration...

Current configuration : 63 bytes
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
end

Router R2 Configuration:

R2#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.12.2    YES NVRAM  up                    up
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Loopback0                  2.2.2.2         YES NVRAM  up                    up
R2#

R2#
R2#show running-config interface fastEthernet 0/0
Building configuration...

Current configuration : 97 bytes
!
interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
 duplex auto
 speed auto
end

R2#show running-config interface loopback 0
Building configuration...

Current configuration : 63 bytes
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
end


Router R3 Configuration:
R3#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.12.3    YES NVRAM  up                    up
FastEthernet0/1            unassigned      YES NVRAM  administratively down down
Loopback0                  3.3.3.3         YES NVRAM  up                    up
R3#

R3#show running-config interface fastEthernet 0/0
Building configuration...

Current configuration : 97 bytes
!
interface FastEthernet0/0
 ip address 192.168.12.3 255.255.255.0
 duplex auto
 speed auto
end

R3#show running-config interface loopback 0
Building configuration...

Current configuration : 63 bytes
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
end

On all the 3 routers still no routing protocols are configured

Let's start configuring EIGRP in all the routers.

R1 Configuration:

R1#conf ter
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#neighbor 192.168.12.2 fastethernet 0/0
R1(config-router)#end
R1#

R2 Configuration:

R2#conf terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router eigrp 1
R2(config-router)#no auto-summary
R2(config-router)#neighbor 192.168.12.1 fastethernet 0/0
R2(config-router)#end
R2#

R3 Configuration:

R3#conf terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#router eigrp 1
R3(config-router)#no auto-summary
R3(config-router)#network 0.0.0.0
R3(config-router)#end
R3#


Till now,
  • EIGRP configuration has been made in all the 3 routers
  • R1 and R2 are configured with static EIGRP using the command "neighbor <neighbor-ip> <local-interface>"
  • R3 is configured with multicast using the network command and note neighbor command is not used in the EIGRP configuration, which means it will send hello packets to all the EIGRP interfaces.

Now, Let's see whether the EIGRP neighbors are formed,

R1 Output:

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
R1#

R2 Output:

R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
R2#

R3 Output:

R3#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
R3#
 
You can see that the neighbor's are still not yet formed. Below are reasons:
  • R1 and R2 are configured as STATIC neighbors, but we haven't updated which network to advertise. Once we advertise the required network neighbor-ship will be formed.
  • R3 will not form neighbor-ship with other routers, because it is using Multicast packets to form neighbor-ship, whereas R1 and R2 are using Unicast (STATIC). [No other routers other than R3 in the topology is using EIGRP Multicast]

R1 configuration to advertise networks:
R1#conf terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#
R1(config)#router eigrp 1
R1(config-router)#network 0.0.0.0
R1(config-router)#end
R1#

R1 EIGRP Configuration:

R1#show running-config | section router eigrp
router eigrp 1
 network 0.0.0.0
 no auto-summary
 neighbor 192.168.12.2 FastEthernet0/0
R1#


R2 configuration to advertise networks:

R2#conf terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#router eigrp 1
R2(config-router)#network 0.0.0.0
R2(config-router)#end
R2#

R1 EIGRP Configuration:

R2#show running-config | section router eigrp
router eigrp 1
 network 0.0.0.0
 no auto-summary
 neighbor 192.168.12.1 FastEthernet0/0
R2#

R1 and R2 EIGRP logs:
R1#
*Mar  1 00:47:56.811: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.12.2 (FastEthernet0/0) is  up: new adjacency

R2#
*Mar  1 00:41:23.271: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 192.168.12.1 (FastEthernet0/0) is up: new adjacency

You can see that the neighbor-ship is formed between R1 and R2. But it will not form because all other routers are configured with STATIC EIGRP (UNICAST).

R1 Neighbor-ship Output:

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.12.2            Fa0/0             12 00:06:26 1222  5000  0  3

R2 Neighbor-ship Output:

R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.12.1            Fa0/0              9 00:06:41   94   564  0  3
R2#

R3 Neighbor-ship Output:

R3#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
R3#

That's it about EIGRP STATIC Neighbor...

You can also look into my video tutorial in Tamil:


Post a Comment